InfoTrac is not working
Incident Report for InfoIMAGE Status Page
Resolved
This incident has been resolved.
Posted Feb 07, 2025 - 13:27 UTC
Investigating
A possible system and/or latency issue has been detected. We are currently working to resolve. Updates will be provided every 30 minutes. Our sincere apology for any inconvenience.
Posted Feb 07, 2025 - 06:16 UTC
This incident affected: InfoTrac.