E-Statement Platform is not working
Incident Report for InfoIMAGE Status Page
Resolved
This incident has been resolved.
Posted Feb 05, 2025 - 23:40 UTC
Update
We are continuing to investigate this issue.
Posted Feb 05, 2025 - 23:39 UTC
Investigating
A possible system and/or latency issue has been detected. We are currently working to resolve. Updates will be provided every 30 minutes. Our sincere apology for any inconvenience.
Posted Feb 05, 2025 - 21:18 UTC
This incident affected: eStatement Prism Platform.